A Digital Age Deserves A Digital Leader

XP multiboot problem

Forum rules
Please start your own topic for support with problems you experience. Even if it appears to be exactly the same as someone else's problem, system configurations differ significantly. Thank you.

It may take our support staff between 24-48 hours to respond to your problem. We are a small business and strive to answer your questions as soon as possible. We appreciate your patience.

XP multiboot problem

Postby HelgeS » Tue Aug 10, 2010 5:16 pm

I finally got my Win 7 multiboot to work, and the SSD configuration FLIES, 30" from end of POST to desktop, after selecting a profile! For backward compatibility, I still want XP available, though, but haven't been able to get it to work reliably. I don't want to set up anything retro as to boot sector, etc. Can you give help for XP BOOT.INI setup? My configuration is as follows, and I know you'll <GROOOAAAN!>:

IDE Ch. 0
master, Memorex DVD (lists as CD-ROM 0 IDd as a DVD, drive G:, in Win 7 Disk Management)
slave, Maxtor 40Gb IDE HD lists as Basic disk 2 in W7 DM, partitioned as
0: system, active, drive I:, has the BCD in its \Boot dir, also the 9x boot files in the root, and 98 boots fine
1: extended, drive H:, plain backup partition w/no O/S
IDE Ch. 1
master only, solo LiteOn CD-ROM (lists as CD-ROM 1 drive J: in W7 DM)
slave, vacant
IDE Ch. 2
master only, SATA: Intel SSD, 80Gb, listed as Basic Disk 0 in W7 DM
partitioned as
0: active, no O/S, drive C: booting from SSD (N: when booting from rotary)
1-3: in extended partition, 2 no O/S D: (O:), 3 XP E: (P:), 4 Win 7 F: (Q:)
IDE Ch. 3
master only, SATA: rotary Maxtor 298Gb partitioned as
0: active, no O/S, drive N: (C: when booting Win 7 from here)
1-3: extended, 2 no O/S O: (D:), 3 XP P: (E:), 4 Win 7 Q: (F:)

DM disks 4 & 5 are USB volumes that appear/disappear when the USB hub is present/absent.

BUT, I can't get XP to start at all after getting the Win 7 multiboots working great. I have ntldr and NTDETECT.COM on I: (BIOS IDE Ch. 0, drive 0, system/active) along with its BOOT.INI, but no matter what parameters I supply in it seem to work. Here's the current state:

[boot loader]
timeout=4
default=multi(0)disk(0)rdisk(0)partition(3)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS=" ...on the rotary"
multi(0)disk(0)rdisk(1)partition(3)\WINDOWS=" ...on the SSD"
c:\BOOTSECT.W98=" Windows 98SE (FAT32 only)"
;c:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /CMDCONS


I put a legacy configuration into the BCD with DualBoot Pro, and tried having it start ntldr from either I:, C:, or N: with the files in all those drives' roots, but when I select from the BOOT.INI-posted menu, I get the configuration error. I assume that there's a problem with the legacy entry, so do I have to provide pre-BCD letters? Am I understanding wrong how Win XP starts? I thought that, when I selected the legacy entry off the BCD boot menu, it runs ntldr from the specified drive, which posts its own boot menu, and starts windows from the \WINDOWS folder of the disk specified in the [operating systems] section, but apparently I have the wrong parameters in there. I have a VIA-chip based Gigabyte MOBO, so I assume that its HD controller is being used for all the IDE drives. I tried all sorts of permutations of the number within the parentheses of rdisk(), but no success.

Thanks for suggestions!
PRO New Member
Posts: 3
Joined: Sat Jul 31, 2010 3:46 am

Re: XP multiboot problem

Postby HelgeS » Tue Aug 10, 2010 9:24 pm

I solved it. This was one of the strangest Windows IT problems I've ever encountered. NOTHING I tried worked, so I reasoned that there must've been something wrong with the actual XP installation on the rotary SATA drive itself, and since I already had a clone of it on the SSD, I blasted the former away with EASUS Partition master, and with it copied the SSD XP onto that unallocated area. Win 7 afterward found some errors in that partition that Chkdsk fixed, and XP on the rotary SATA drive now starts when with BOOT.INI configured like this:

[boot loader]
timeout=8
default=multi(0)disk(0)rdisk(1)partition(3)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(3)\WINDOWS=" ...on the SSD"
multi(0)disk(0)rdisk(2)partition(3)\WINDOWS=" ...on the rotary"
c:\BOOTSECT.W98=" Windows 98SE (FAT32 on C: only)"


Then, another strange but cosmetic problem cropped up: The nice animation disappeared from the startup of the rotary SATA's Win 7, and was replaced with an old-style green barometer. I guess that's OK, for it quickly tells me that the S*L*O*W rotary SATA W7 installation's the one loading :whistle , not the SSD's (which has the nice gradient-flag animation). I wonder what startup thing got clobbered there? It seems to work fine otherwise. Anyway, I now have XP and 7 installations bootable off both SATA drives, and I guess I'll disable/reletter the non-O/S partitions in the rotary-SATA installations, so they point to/access the partitions on the SSD with the same letters, and I should be free from file async. When I'm 100% confident with the SSD installations, I guess I can abandon the rotary stuff, and use the drive for backup.

So far I can heartily recommend the Intel X-24M SSD: It's lightning fast and reasonably priced. Bloated files not commonly needed can be kept off it on a mechanical HD.

Low-level O/S asynchronicity wierdnesses like this are the PITS!
PRO New Member
Posts: 3
Joined: Sat Jul 31, 2010 3:46 am

Return to Windows Boot Problems

Who is online

Users browsing this forum: No registered users and 0 guests

cron
cron