A Digital Age Deserves A Digital Leader

Roaming Profile Issues on Windows 7

Roaming Profile Issues on Windows 7

Postby mnemonicj » Thu May 07, 2009 3:17 am

I decided to dive into Windows 7 RC because of the convenience features over Windows Vista. I have a Windows Server 2003 Domain Controller with Windows Vista Business as a client. Everything was working fine when I decided to format my computer and put Windows 7 on it. The install went well, Windows 7 was able to load my roaming profile and everything seemed to work fine, but when I restarted the computer a logoff notification messages told me that the roaming profile was not saved.

I checked the error log and there was a 1504 event that stated the roaming profile could not be saved to the server and the event told me to look at previous events to find out the reason why, except there were no previous events that were even slightly related. Well, to tell the truth there were registry unloading issues because of Defender, but after I disabled the Defender service, the 1504 event was still there every time I logged off.

I am throughly confused because everything was working fine with Windows Vista.

Anyone else using roaming profiles with Windows 7 and having issues?
PRO Level 15
User avatar
Posts: 1066
Joined: Tue Aug 17, 2004 1:41 am
Location: Indianapolis, IN

Re: Roaming Profile Issues on Windows 7

Postby mnemonicj » Fri Jun 19, 2009 2:49 pm

After going back to Vista for the past month and a half, I finally decided to dual boot Vista Business and Windows 7 RC to see if I still had the same problem. Initially, it seemed that the problem was still there, my roaming profile would not save to the server. But, for some unknown reason, it has been fixed. I am not sure if it was the Microsoft update that fixed it or what, but it is fixed and Windows 7 is updating my roaming profile. ^*^

Now I can use Window 7 RC as my main OS and I still have Vista Business to fall back on with my profile settings intact!
PRO Level 15
User avatar
Posts: 1066
Joined: Tue Aug 17, 2004 1:41 am
Location: Indianapolis, IN

Re: Roaming Profile Issues on Windows 7

Postby yeshuas » Fri Jun 19, 2009 3:15 pm

I am getting ready in the next couple days to set up a domain controller at home, so your info is helpful, since I am planning on using Server 2008 and Windows 7 on clients along with XP Pro.
Game Over!!!!!!!!
Image
ASUS Maximus V Gene MB
Windows 8 X64; Windows 7 X64; Windows 7 X86
Intel I5-3570K
16GB Corsair Vengeance Ram
eVGA GeForce GTX 550 TI
Corsair GS700 PS
1TB Seagate SATA 6.0Gb HD
Thermaltake Case
Software Development
User avatar
Posts: 5075
Joined: Wed Jan 17, 2007 3:29 pm
Location: Chicago, IL
Real Name: Daniel Schmidt

Re: Roaming Profile Issues on Windows 7

Postby mnemonicj » Fri Jun 19, 2009 4:20 pm

One bad thing about using XP and Vista/Windows 7 on the same domain is that the there are 2 different roaming profiles since the roaming profiles for XP and Vista/Windows 7 are not compatible. In the folder where you have your roaming profiles located, you will have two folders for each user:

<username>
<username>.V2

So if your username is Frank, you will a folder named Frank for your Windows XP roaming profile, and a folder named Frank.V2 for your Windows Vista/7 roaming profile.

Because of the separate folders, the two roaming profiles will not share information.
PRO Level 15
User avatar
Posts: 1066
Joined: Tue Aug 17, 2004 1:41 am
Location: Indianapolis, IN

Re: Roaming Profile Issues on Windows 7

Postby mnemonicj » Mon Jun 22, 2009 5:15 am

OK, I spoke too quickly. When I installed Windows 7, there was not indication from the Windows 7 machine that the roaming profile was not being updated, but it was not updated. I looked on my server and found that the last time the ntuser.dat file was updated on my roaming profile on the server and it was Thursday, June 18th in the evening (the last day I logged off of Windows Vista before installing Windows 7). So, that means that Windows 7 loaded the roaming profile from the server, but never made any updates to the server since it has been installed.

I have been looking all over the Internet for a solution to this issue and have yet to find it. Maybe Windows Server 2008 won't have this issue, but I know that Windows Server 2003 does.
PRO Level 15
User avatar
Posts: 1066
Joined: Tue Aug 17, 2004 1:41 am
Location: Indianapolis, IN

Re: Roaming Profile Issues on Windows 7

Postby Jurren » Sun Jun 28, 2009 12:25 am

This profile issue is driving me mad too.. My old profile is loading correctly but also not saved at logoff. I've already tried to create a new profile share, everyone full control to avoid acl issues. Even removed all local profiles, cleaned all profiles, and logged on. Nice new profile, everything is saved nicely across settings..........locally. Argh.. The roaming profile stays completely empty. When I fill this newly created empty profile (automatically created by Windows 7, so there should be no acl problems) with my old profile it loads nicely at logon, but again... Settings are only saved locally! Grr. No strange events on server or locally, profile is designated as "roaming" in system properties.

Ab-solutely no clue of what is going on..

This thread is the only place I found wich describes the same problem as I am having. Is it a rare problem or are there not enough Windows 7 beta testers which post their problems? (AND solutions please ;-)

I have a small hunch it has to do something with a new function that should be implemented in this version. Roaming profiles are not only synchronized during logoff but are kept synchronized during your session:

http://thegreenbutton.com/forums/thread/345725.aspx
-Roaming User Profiles – now the user profiles are automatically synchronized with the server wil you are still logged in, and can roam from one PC to another while remaining logged in on both, and still have the same consistent environment.

Very nice feature, long awaited and hoped for, but could it be broken (in our situation)?? As I said: just a hunch..

Please keep me informed about your progress, hopefully the fix is not far away!
PRO New Member
Posts: 4
Joined: Sat Jun 27, 2009 11:56 pm

Re: Roaming Profile Issues on Windows 7

Postby Jurren » Sun Jun 28, 2009 12:36 am

Seems that this new roaming profile functionality is nothing special:

http://blogs.sepago.de/helge/2009/04/02/microsoft-tackles-the-last-writer-wins-problem-of-roaming-profiles-in-windows-7-server-2008-r2/

Reading this makes me think this simple addition of saving your profile more often and flushing a fresh ntuser.dat in your roaming profile should not interfere with normal saving of your profile at logoff. So now I'm totally clueless again... Sigh.
PRO New Member
Posts: 4
Joined: Sat Jun 27, 2009 11:56 pm

Re: Roaming Profile Issues on Windows 7

Postby mnemonicj » Sun Jun 28, 2009 4:05 am

I wondered if the new functionality of the roaming profile might be the issue. I can't understand why Microsoft would even dream of making Windows 7 and Windows Server 2003 incompatible in the part of roaming profiles. That means that every company that wants to move over to Windows 7 would need to have all of their domain controllers switched to Server 2008 before the Windows 7 switch. That sounds like something Apple would do, not Microsoft.

I have read of people having this issue with the Beta and RC Windows Vista, but it was mostly due to how horrible Windows Defender is. It did make me think for a minute though that maybe Microsoft doesn't enable roaming profiles in the pre-RTM versions of the OS, but I have nothing to back that up with.
PRO Level 15
User avatar
Posts: 1066
Joined: Tue Aug 17, 2004 1:41 am
Location: Indianapolis, IN

Re: Roaming Profile Issues on Windows 7

Postby Jurren » Sun Jun 28, 2009 10:05 pm

I think I found it, but I just can't believe it:

http://www.tomshardware.co.uk/forum/page-37056_35_0.html

Yes, this issue is on Windows XP. Yes, this issue dates from 2004. But: YES: Disabeling the Microsoft certified, automatically installed, factory shipped NVIDIA Display Driver Service seems to solve the issue. :confused

I am reluctant to believe this very old issue surfaces again in Win7, but I disabled this service, rebooted, logged on, logged off and voila, my profile was updated. It was immediately clear this made the difference, logging off took much more time than with an enabled Nvidia service. But WHY does a MS certified driver, shipped with Win7, cause this? Well, let's say not all RC's make it to gold status...

So don't believe me, I sure as hell don't believe it myself, but just try. And post if you experience the same effects. Hope this helps!
PRO New Member
Posts: 4
Joined: Sat Jun 27, 2009 11:56 pm

Re: Roaming Profile Issues on Windows 7

Postby Jurren » Sun Jun 28, 2009 10:14 pm

PRO New Member
Posts: 4
Joined: Sat Jun 27, 2009 11:56 pm

Next

Return to General Windows Support

Who is online

Users browsing this forum: MSN [Bot] and 2 guests