A Digital Age Deserves A Digital Leader

ndiswrapper load at startup? *SOLVED*

ndiswrapper load at startup? *SOLVED*

Postby Craigular.B » Tue Jul 08, 2008 12:16 am

Hey guys,

I just got my D-Link DWA-130 running today with ndiswrapper on Ubuntu 8.04 (i386 version, 'cause DLink doesn't have 64-bit drivers so I had to tank my 64-bit version and reinstall with my x86 disc), and I love it. The only problem is, every time I restart the computer into Ubuntu, I have to run

Code: Select all
sudo depmod -a

and

sudo modprobe ndiswrapper


to get the card to work (be recognized and connect to the network). I don't have to reinstall the INF file, that stays persistent. I tried running "sudo ndiswrapper -m" like https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper said to under "Automatically load at startup", but no luck. I used the 1.30 driver straight from D-Link's site after I installed it on XP and grabbed the inf and sys files I needed.

So, my question is does anybody have any solutions to get ndiswrapper to run automatically at startup so I don't have to open a terminal window and type that stuff in every time?

Thanks!
-Craig


EDIT Well, had I tweaked my Google search a tiny bit, I would've found what I was looking for. The Ubuntu help page did not have one helpful command that was necessary to finish the autoload configuration:
Code: Select all
echo 'ndiswrapper' | sudo tee -a /etc/modules

I ran that, re-ran "sudo ndiswrapper -m" just to be safe, restarted, and my wifi now works no problems. Found my answer on the Ubuntu Forums, not the How-To wiki. Sorry for the useless post, maybe it'll help somebody else....END EDIT
PRO Level 3
User avatar
Posts: 70
Joined: Sat Mar 26, 2005 5:34 pm
Location: Marquette MI
Real Name: Craig Belpedio

Return to Other Operating Systems

Who is online

Users browsing this forum: No registered users and 2 guests

cron
cron