A Digital Age Deserves A Digital Leader

how to disable "FAST IO disallowed" ?

how to disable "FAST IO disallowed" ?

Postby Azjo » Thu Dec 31, 2009 5:50 am

I found this strange problem when i was wondering why defraggler was slow (turns out defraggler just cannot handle too many files when doing a full defrag, and therefore uses 100% cpu)

I used process monitor to find out and here is the info:

Date & Time: ###
Event Class: File System
Operation: DeviceIoControl
Result: FAST IO DISALLOWED
Path: F:
TID: 3300
Duration: 0.0000041
Control: IOCTL_SCSI_PASS_THROUGH_DIRECT

However, after the "fail" there is always a success listed in process monitor so im not sure if there really is a problem. But obviously id like Fast io processing for performance ;)
I believe it has something to do with IOCTL_SCSI_PASS_THROUGH_DIRECT but im not sure if its even possible to tinker with a setting related to that, if so it should be the SCSI controller i believe.
Its just the basic scsi initiator which came with vista.
PRO Level 3
Posts: 59
Joined: Thu Feb 15, 2007 6:28 pm

Re: how to disable "FAST IO disallowed" ?

Postby jbullard » Thu Dec 31, 2009 8:34 pm

Azjo,

Looks like you need to update your chipset drivers. This should fix the problem. :yesnod:
VP - Software
User avatar
Posts: 3653
Joined: Sun Jun 06, 2004 10:17 pm
Location: Utah
Real Name: Jason Bullard

Return to General Windows Support

Who is online

Users browsing this forum: No registered users and 0 guests